CentOS 8安裝docker-ce

第一次安裝CentOS 8 , 也第一次在上面安裝docker-ce版本,因此記錄下來版本不一致衝突的解決方式

簡單的敘述就是 CentOS 8 目前的containerd-io 版本低於 1.2.2-3 , 無法安裝docker-ce 19版本 , 處理方式就是先手動安裝大於1.2.2-3的containerd-io

dnf install -y epel-release
dnf update
dnf install -y yum-utils  device-mapper-persistent-data lvm2
dnf config-manager --add-repo=https://download.docker.com/linux/centos/docker-ce.repo
## containerd.io-1.2.2-3以上
wget https://download.docker.com/linux/centos/7/x86_64/stable/Packages/containerd.io-1.2.6-3.3.el7.x86_64.rpm
rpm -Uvh containerd.io-1.2.6-3.3.el7.x86_64.rpm
dnf -y  install docker-ce-cli docker-ce --nobest
systemctl enable docker
systemctl start docker
################################################
## 安裝完畢,請更改預設存放路徑
## 編輯 /lib/systemd/system/docker.service
## 找出
## ExecStart=/usr/bin/docker 
## 改成
## ExecStart=/usr/bin/docker  -g <你的新路徑>
################################################

發表迴響